立即注册

micropython-microbit 中文社区

查看: 214|回复: 5

[求助] Microbit电机运行出现问题,请问下专家朋友知道这是为什么吗

  [复制链接]

该用户从未签到

发表于 2019-4-17 13:48:03 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
本帖最后由 谭耀喜 于 2019-4-17 13:56 编辑
  1. from microbit import *
  2. import neopixel
  3. from random import randint

  4. np = neopixel.NeoPixel(pin0, 15)

  5. def motor(a, b):
复制代码
在Microbit中定义好电机的引脚接口及运动、停止函数,在之前调试都是可以的,但是最近再来用的时候,电机不运行了,灯带是可以点亮的。专家们知道是什么原因吗?编辑器采用的是离线版的Mu_Editor

电机程序

电机程序
回复

使用道具 举报

  • TA的每日心情
    慵懒
    2019-10-23 20:05
  • 签到天数: 9 天

    [LV.3]偶尔看看II

    发表于 2019-4-17 14:43:16 | 显示全部楼层
    先用万用表看看pin8和pin12是否有输出信号,在检查电机驱动板是否正常。
    回复 支持 反对

    使用道具 举报

    该用户从未签到

     楼主| 发表于 2019-4-17 15:52:40 | 显示全部楼层
    shaoziyang 发表于 2019-4-17 14:43
    先用万用表看看pin8和pin12是否有输出信号,在检查电机驱动板是否正常。

    好的,谢谢邵老师!
    回复 支持 反对

    使用道具 举报

    该用户从未签到

     楼主| 发表于 2019-4-18 14:05:57 | 显示全部楼层
    本帖最后由 谭耀喜 于 2019-4-18 14:08 编辑
    shaoziyang 发表于 2019-4-17 14:43
    先用万用表看看pin8和pin12是否有输出信号,在检查电机驱动板是否正常。

    用万用表检测P8和P12引脚无信号输出,只有微弱的电压0.01毫伏,邵老师,有什么破解办法吗?用的是下面这种扩展板:

    T型扩展板

    T型扩展板
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    慵懒
    2019-10-23 20:05
  • 签到天数: 9 天

    [LV.3]偶尔看看II

    发表于 2019-4-18 16:35:11 | 显示全部楼层
    谭耀喜 发表于 2019-4-18 14:05
    用万用表检测P8和P12引脚无信号输出,只有微弱的电压0.01毫伏,邵老师,有什么破解办法吗?用的是下面这种 ...

    不存在破解,看看是不是引脚没有接触好,电源供电是否正常,或者microbit插反了
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    2019-10-6 19:57
  • 签到天数: 62 天

    [LV.6]常住居民II

    发表于 2019-7-9 21:30:29 | 显示全部楼层

                                   
    登录/注册后可看大图

    run函数的问题:两个引脚的电平不能一样,要一个高,一个低,改成这样
    def run():
        motor(1,0)
    回复 支持 反对

    使用道具 举报

    游客
    回复
    您需要登录后才可以回帖 登录 | 立即注册

    Archiver|手机版|小黑屋|micropython-microbit 中文社区

    GMT+8, 2019-12-16 09:54 , Processed in 0.100881 second(s), 23 queries .

    Powered by Discuz! X3.4

    © 2001-2013 Comsenz Inc.

    快速回复 返回顶部 返回列表