立即注册

扫一扫,访问微社区

micropython-microbit 中文社区

查看: 457|回复: 14

DAPLink固件升级到0251

  [复制链接]
  • TA的每日心情
    奋斗
    2019-1-26 00:03
  • 签到天数: 6 天

    [LV.2]偶尔看看I

    发表于 2018-11-9 09:17:43 | 显示全部楼层 |阅读模式

    马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x
    昨天DAPLink再次进行了升级,目前版本是0251。为了方便大家,中文社区将microbit固件单独提取出来,方便大家使用。

    0251_kl26z_microbit_0x8000.zip (59.49 KB, 下载次数: 37)

    手机扫码浏览
    回复

    使用道具 举报

    该用户从未签到

    发表于 2018-12-18 16:18:43 | 显示全部楼层
    我也尝试编译DAPLINK 是microbit支持webusb 但是一直表一个汇编文件的错误 不知道是咋回事
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2019-1-26 00:03
  • 签到天数: 6 天

    [LV.2]偶尔看看I

     楼主| 发表于 2018-12-18 16:37:50 | 显示全部楼层
    八哥 发表于 2018-12-18 16:18
    我也尝试编译DAPLINK 是microbit支持webusb 但是一直表一个汇编文件的错误 不知道是咋回事 ...

    通常是工具链的问题
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2018-12-18 21:53:43 | 显示全部楼层
    shaoziyang 发表于 2018-12-18 16:37
    通常是工具链的问题

    编译低版本的 比如 246就没有问题 但是编译新的固件就报错了呢
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2019-1-26 00:03
  • 签到天数: 6 天

    [LV.2]偶尔看看I

     楼主| 发表于 2018-12-18 22:36:26 | 显示全部楼层
    八哥 发表于 2018-12-18 21:53
    编译低版本的 比如 246就没有问题 但是编译新的固件就报错了呢

    新版本还没有试过,抽空看看
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2018-12-18 22:37:35 | 显示全部楼层
    shaoziyang 发表于 2018-12-18 22:36
    新版本还没有试过,抽空看看

    反正我编译就一个汇编文件报错
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2018-12-23 23:18:03 | 显示全部楼层
    楼主你编译daplink  microbit  248以上版本的固件吗?我编译一直报下面这个错误,求指导呀,感谢了,我48  49  50  51 这四个版本的固件都编译了Microbit的固件都试过,都是报这个错误,度不知道怎么修改呀,

    compiling RTX_Config.c...
    assembling SVC_Table.s...
    SVC_Table.s: Error: C3472E: No source language specified (--cpp or --c90) and sourcefile extensions conflict
    SVC_Table.s: error: A1905U: Pre-processor step failed for '..\..\..\source\daplink\interface\SVC_Table.s'
    ".\build\kl26z_microbit_if.axf" - 2 Error(s), 0 Warning(s).
    Target not created
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2019-1-26 00:03
  • 签到天数: 6 天

    [LV.2]偶尔看看I

     楼主| 发表于 2018-12-24 09:15:58 | 显示全部楼层
    八哥 发表于 2018-12-23 23:18
    楼主你编译daplink  microbit  248以上版本的固件吗?我编译一直报下面这个错误,求指导呀,感谢了,我48   ...

    抽空试试
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2018-12-24 09:40:49 | 显示全部楼层

    很期待呀,我反正编译48以上的microbit以上的固件都是这个问题,48一下的固件就没有这个问题,也不知道怎么解决这个问题,楼主你这个固件不是你自己编译出来的?
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2019-1-26 00:03
  • 签到天数: 6 天

    [LV.2]偶尔看看I

     楼主| 发表于 2018-12-24 10:20:38 | 显示全部楼层
    八哥 发表于 2018-12-24 09:40
    很期待呀,我反正编译48以上的microbit以上的固件都是这个问题,48一下的固件就没有这个问题,也不知道怎 ...

    DAPlink发布的固件中包括了常用板卡,就有microbit的。
    回复 支持 反对

    使用道具 举报

    游客
    回复
    您需要登录后才可以回帖 登录 | 立即注册

    关闭

    站长推荐上一条 /3 下一条

    Archiver|手机版|小黑屋|micropython-microbit 中文社区 ( 鄂ICP备17012469号 )

    GMT+8, 2019-2-20 13:34 , Processed in 0.129732 second(s), 27 queries .

    Powered by Discuz! X3.4

    © 2001-2013 Comsenz Inc.

    快速回复 返回顶部 返回列表